ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Reply Subscription Options  

Flash in Class Connection, also You Tuve

Forums: Class Connection Bugs
Created on: 02/25/14 07:54 PM Views: 1582 Replies: 17
Tuesday, February 25, 2014 at 7:54 PM

In my website, anadarkohs60.com, the very top 3 Announcements on my Home Page are messed up. In order of presentation they are 1) Announcement of one of our other classes having a reunion soon, 2) You Tube video of School Band, and 3) Rotating Map.

All three wipe out my Background color of the Announcements for some reason???? Per item, in respective order:

1. Announcement about one of our other classes having a Reunion soon. Link does not work in Firefox, but works in IE 11.

2. You Tube of School Band. Nothing shows in Firefox, works fine in IE 11.

3. Rotating Map. It is in Java, nothing works in either Browser. I earlier tried using the Rotating Map widget from www.revolvermaps.com using HTML instead of Java. Those don't seem to work either. I guess they need the newer version of HTML.

Any projection when some of the above will be resolved, especially the wipe out of background color and displacement of the widgets. Secondly of course is Java versus HTML version types (perhaps a guide on what to start looking for as replacement if this will be restricted). Finally, why would IE 11 function for Links while Firefox does not?

Reply
Edited 02/25/14 7:56 PM
Tuesday, February 25, 2014 at 8:39 PM - Response #1

We'll take a look at the color.

All right, let's dissect this:

1) Link not working: Programming will fix this.

2) All third party items must begin with https instead of http to work on Facebook. While some third parties do not support https, fortunately YouTube does and I was able to fix the video. I don't know why it's not centered though like the web site. Will ask Programming to look at the formatting there.

3) Possibly not supported by https. I tried adding https to this and it failed. Put it back to http. Will run this one past Programming.


Derrell Pulis wrote:

In my website, anadarkohs60.com, the very top 3 Announcements on my Home Page are messed up. In order of presentation they are 1) Announcement of one of our other classes having a reunion soon, 2) You Tube video of School Band, and 3) Rotating Map.

All three wipe out my Background color of the Announcements for some reason???? Per item, in respective order:

1. Announcement about one of our other classes having a Reunion soon. Link does not work in Firefox, but works in IE 11.

2. You Tube of School Band. Nothing shows in Firefox, works fine in IE 11.

3. Rotating Map. It is in Java, nothing works in either Browser. I earlier tried using the Rotating Map widget from www.revolvermaps.com using HTML instead of Java. Those don't seem to work either. I guess they need the newer version of HTML.

Any projection when some of the above will be resolved, especially the wipe out of background color and displacement of the widgets. Secondly of course is Java versus HTML version types (perhaps a guide on what to start looking for as replacement if this will be restricted). Finally, why would IE 11 function for Links while Firefox does not?


Reply
Tuesday, February 25, 2014 at 8:51 PM - Response #2

Thanks so much Brad. Just a few things like this, and I will invite the entire class. I expect the Class Connection to be pretty popular with us 70 year olds. Other less obvious things will iron out over time. I just want it to still look nice. Smile

Reply
Tuesday, February 25, 2014 at 9:08 PM - Response #3

Yup! Me too. We're probably going to spend the next couple months or so ironing out things like this. No amount of testing can turn up some of the issues like this we're going to find when live.. Back to you on this as soon as possible hang tight.


Reply
Tuesday, February 25, 2014 at 9:24 PM - Response #4

Suddenly, I am getting RevolverMaps to function, but only in Firefox so far. I have 2 maps on, the original (which is distorted and apparently I live several hundred miles out in the Pacific ocean). Another I have pasted the full globe just as a test on capabilities. Both are in Flash. Anything with Flash change there in last hour or so? SmileSmile

Reply
Tuesday, February 25, 2014 at 10:40 PM - Response #5

Only the video works for me on FB in FF.

I'm stuck for the moment on IE10 Win8 (long story) and same thing there - none of the objects show. Not even the video which is https. Must be because of the next problem:

Video lack of centering is because h2 center tag is not there. It's using the wrong tags (which had to be created by the classconnection app).

Reply
Wednesday, February 26, 2014 at 12:10 AM - Response #6

Brad, I have got pretty well 'everything in this post now displaying, but ONLY in IE 11. Only one that shows in Firefox is the You Tube video. Biggest problem though is still the background color wipe out to white. Almost seems like it can't make up its mind which browser to function within. Smile

Derrell Pulis wrote:

Suddenly, I am getting RevolverMaps to function, but only in Firefox so far. I have 2 maps on, the original (which is distorted and apparently I live several hundred miles out in the Pacific ocean). Another I have pasted the full globe just as a test on capabilities. Both are in Flash. Anything with Flash change there in last hour or so? SmileSmile

Reply
Edited 02/26/14 12:11 AM
Wednesday, February 26, 2014 at 12:34 AM - Response #7

This is due to differences in how a browser enforces security.

IE allows you to run non-https (http) within https (but it asks you first - so that's a non-starter in some ways). If I say NO, then none of the objects show. It's not really a good option since it bypasses security and make you vulnerable in iframes!

FF always enforces non-https Flash references inside of https. So that's why it's different.

Chrome also doesn't work. So 2 of the top 3 browsers do not work and #3 has a prompt to bypass security.

Basically, unless an external site runs as https, it should not be used.

Reply
Wednesday, February 26, 2014 at 11:30 AM - Response #8

Hang tight until a Programer has a chance to look at this. Everything that can be fixed will be, and for anything that can't be fixed, we'll at least have a reason why and a suggestion, such as remove something entirely or replace it with something else (e.g. something third party simply isn't compatible with https). I expect to have more for you on this on Monday or before.


Reply
Thursday, February 27, 2014 at 12:15 PM - Response #9

Yellow background fixed.

I targeted the link to a new window, which makes it work in Firefox. This needs further investigation. Link should work like it does in IE. Looking into this.

Video centering fixed.

Doesn't look like third party revolver map supports https. Options are:

1) remove it
2) replace it with something else that supports https
3) Make an alternate FB home page version (when this becomes available)


Reply
Friday, February 28, 2014 at 12:43 AM - Response #10

Good on link.


Reply
Thursday, March 20, 2014 at 2:02 PM - Response #11

Brad Switzer wrote:

....

2) All third party items must begin with https instead of http to work on Facebook. While some third parties do not support https, fortunately YouTube does and I was able to fix the video....

I added the "s" to the source code for a YouTube video I have under For Your Enjoyment - Memories and I still do not see it on Class Connection. Do I need to do something different?

Reply
Thursday, March 20, 2014 at 6:40 PM - Response #12

You almost had this right. You changed one of the embed links to https correctly, but you didn't change the other. Both needed to be changed to include the s to work. I added the missing s and you're good to go here.


Reply
Thursday, March 20, 2014 at 6:57 PM - Response #13

Thanks! I've got it now.

Reply
Thursday, March 27, 2014 at 11:45 PM - Response #14

Am i to understand that this was a known problem before you launched. Did i miss the warnings you sent out to tell people to fix these issues?

Reply
Friday, March 28, 2014 at 12:50 PM - Response #15

Various link issues were reported when people began using Class Connection. Automated solutions were put in place for several things like YouTube, Issue, and relative URL and full URL links are better handled now. Any link issues please report, and there's either an automated solution, or if nothing else rules you can count on to resolve most link issues (such as creating a relative link if you want to keep a page within the app, and a full URL link if you don't). We'll get something in the FAQs about this but for the most part we're hoping to automate most link issues so people don't need to make manual changes.


Reply
Friday, March 28, 2014 at 1:40 PM - Response #16

See this TOPIC where I give an example where it shows link problems. Some can't be solved manually because fixing it for FBCC causes problems on CC. Those are the ones that are PW. IOW, CC code has to do it correctly.

I finally saw what the coding mistake is in this whole area of links:

1. If the first page is a reference to a "normal" CC page, then on the first page there the links are converted correctly.

2. If the reference is to a gallery, NO links are converted. IOW, code thinks that galleries are only galleries, but that's not true. Many pages are "galleries" and yet none are 'picture' galleries. It was the only way to get unlimited links in the previous version. I'm not the only one that did this.

3. Linking to other pages within either #1 or #2 (we link to other Gallery pages in both types) are also not properly converted. They ARE "translated" since they have https added and nothing else. That code needs to look for domain name -> to CC URL conversion too.

So the code knows how to do this, but it deliberately is ignoring the pages I described.

The other issue is that although I've manually fixed some image references (tedious), there's also no need for the code to add https to images.

For CC stored data, can work with proper domain URL conversion same as the links or better yet just LEAVE THEM ALONE.

The latter is the better solution since some people have images from other sites that do not support https. This will avoid further posts here about images that don't show up on FBCC.

I think this is the fourth time I've tried to explain these conversion issues. Wink

Reply
Edited 03/28/14 1:43 PM
Friday, March 28, 2014 at 10:17 PM - Response #17

responded in other thread regarding this.


Reply
New Topic Reply  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.