| Blockbuster sites, amazing reunions

Share Tips

New Topic Reply Subscription Options  

Home Page Is Messed Up

Forums: General Discussion
Created on: 06/08/16 04:48 AM Views: 1179 Replies: 6
Wednesday, June 8, 2016 at 4:48 AM

One of the other administrators posted an announcement and now the home page is out of whack. Can you take a look at it? Thanks.

Wednesday, June 8, 2016 at 8:51 AM - Response #1

I don't know which system (Mac or Windows) you are using, but you can easily see what the problem is by viewing your home page as SELECTED. On Windows, I can type "CTRL-A" and it will select everything on the home page. Then if I scroll down to where the announcements appear, I can see that the announcement is using the SPACE BAR to format the text. This is VERY BAD. Multiple spaces in the text mean "non-wrapable" spaces, so the browser cannot wrap the text on that space. This causes all of the spaces to be treated as one character that cannot be wrapped except before the first space or after the last space.

To fix the problem, edit the announcement and reformat the text to not use multiple spaces in a row.

HINT: It happens in two places, after "page)." and after "advance,"

Wednesday, June 8, 2016 at 1:12 PM - Response #2

Kyle's recommendation is the simplest, however, if you really want to indent this is how to do it since you can still change the text at any time. #4

Indent paragraphs with CSS. CSS paddings or margins give direct display instructions to the browser, so the result is more consistent. It's not hard to add this even if you don't know CSS and do not have a style sheet. Here's an example that shifts the entire paragraph to the right:[5]

"p.indent" defines a type of paragraph (p tag) named "indent" (you can use any name). The rest of the code adds blank space "padding" to the left of these paragraphs.
Now return to the body of your HTML document. Any time you want to indent a paragraph, place it inside these tags:

To adjust the amount of indentation, change the "1.8" number in the CSS code. Keep the "em" after it, which is a measure of length related to the font size.[6]

Wednesday, June 8, 2016 at 9:26 PM - Response #3

OK, I did that. Thanks, Kyle. Now how do I get rid of all the white space and get the announcements back to the top of the page? I'm on Windows, using the latest version of Firefox.

Edited 06/08/16 10:28 PM
Wednesday, June 8, 2016 at 10:32 PM - Response #4

After "Susan ('78 Senior Class TTeasurer) " there is another string of & nbsp's. Remove those and it will come back up.

The easiest way to spot this is to click the "source" view icon (upper left) in the CC editor to remove extraneous html that can interfere.

Wednesday, June 8, 2016 at 11:04 PM - Response #5

It's fixed now

Wednesday, June 8, 2016 at 11:32 PM - Response #6

Kyle Erickson wrote:

It's fixed now

Thanks, Kyle.

New Topic Reply  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.