ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Subscription Options  

Changing Website Design

Forums: Questions and Answers About Building Your Site
Created on: 07/15/11 01:51 PM Views: 1261 Replies: 11
Friday, July 15, 2011 at 1:51 PM

Hi, Guys.

I was considering changing the design of my site to Professional #4.

I am currently using Professional #2 but would like to 'lose' some of the page headings in the left hand column and this looked the best option.

However, when I change to Professional #4 the Home Page blows out. It's only the Home Page that this happens to so I imagine I've got something on there that's too wide for that design. Could you possible take a look please and suggest what it probably is.

I know you've been considering releasing other designs so, before I make up my mind whether to go ahead can you possibly give me some indication as to how far away we are from the new designs.

I'd also like to re-order my page headings list and was thinking about using the Gallery pages to help with this but if there's something else in the pipeline that's going to allow me to re-order more easily could you please give me some idea of when that's likely to come through.

Many thanks.

Reply
Sunday, July 17, 2011 at 12:13 PM - Response #1

Tinyf,

I looked and looked, but couldn't find out what is causing the blowout.


Reply
Tuesday, July 19, 2011 at 8:16 AM - Response #2

Thanks, Kyle. Not sure what I should do next then.

Are you able to answer my other query about when new designs will be coming through?

Reply
Tuesday, July 19, 2011 at 8:40 AM - Response #3

No, I don't know when they will be released. I think they are part of the ClassCreator 3.0 code which the programmers are still working on.


Reply
Tuesday, July 19, 2011 at 8:44 AM - Response #4

To help you solve which section of code is causing your problems, you could copy/paste all of your home page SOURCE code into a text editor (like notepad or some other text editor), then delete all of your home page content. Change to the new format, then copy sections of the code at a time and paste them to the new blank home page SOURCE page and save, then view the page. If it has a problem, then the section of code you just pasted is causing the problem.

If you were using the announcements feature, you could do similar testing by pressing the VIEW button which will display the home page content with just that announcement being displayed.


Reply
Sunday, July 24, 2011 at 11:15 AM - Response #5

Thanks, Kyle. I might do that when I get time.

The problem also occurs with Professional Design #5, though it only blows out on the right hand side of the page instead of both sides as it does with Professional Design #4.It's only happening with those designs that display some of the page headings at the top.

Reply
Thursday, July 28, 2011 at 5:46 PM - Response #6

Sorry to trouble you guys with this again, but it is starting to annoy me as I can't figure out the what's causing the problem.

I went ahead and changed my site design to Professional Design #4 and moved all the aditional pages I'd created using Survey Maker over to pages created with Gallery Creator so that I could organise the pages into the order I wanted.

I'm not sure I've done it absolutely correctly so I'd be very grateful if someone could take a look for me to check that I have.

What I did seems to have created two problems -

1) When using Professional Design #4 two of the pages blow out when I load them and stay blown out. They are -

a) Home
b) Sloane's History

Kyle has already kindly looked at the Home page problem for me but was unable to find what was causing it. I've also looked and was able to rectify the problem on other pages by adjusting some image and link widths, but not on all pages

Others start to blow out then settle to the width they should be when I load them. They are -

a) School Photos
b) Contact Us
c) A Way With Words
d) User Forums
e) Very Interesting
f) Grumpy Old Men
g) Memories of Sloane

The other pages seem to load ok.

2) Since I started using the Gallery Creator pages, if I edit them for any length of time the text in the Editor suddenly 'breaks up' and the page headings in the left hand column disappear! This has happened four times now and the only way I can return things to normal is by rebooting my computer. Unfortunately, this means losing the work I've just entered because I haven't been able to see the 'Save' button.

Please do your best to help.
Many thanks - in anticipation of some success!

Reply
Friday, July 29, 2011 at 11:21 AM - Response #7

There was a blockquote around your calander on the homepage. I removed that code and fixed the homepage layout.

On the Sloane History page, there was a full link path that was longer than the page was wide. IE does not understand how to wrap a link. I simply made the link say Please Click Here. - Fixed

I do not understand #2 other than to say IE does some funny caching things sometimes. I see more issues with IE than when I use Firefox for working on my sites. I'd try a change in browsers and see if that helps.

Scott


Reply
Friday, July 29, 2011 at 3:08 PM - Response #8

Many thanks for your time and trouble Scott.

The pages are not remaining blown out now although they do still 'jump' initially when they load up and then fall into place.

I also noticed (eventually!) the things you mention and also started correcting them. I just hope we both weren't working at the same time and I've now messed up your corrections. If you get time, I'd be grateful if you'd take another look to make sure.

Regarding #2 - I now believe the problem to have been with my computer and Windows. A similar thing started happening when I was using Outlook Express. I decided to use System Restore to go back a week and as I was doing so I got an onscreen message I'd never seen before telling me that I needed to reactivate Windows as hardware changes I'd made (I hadn't) since Windows was first installed had affected Windows significantly.

I've just done a little more editing on the site and didn't have a problem. I pray it remains that way.

Thanks once again.

Reply
Friday, July 29, 2011 at 5:23 PM - Response #9

Mark Foulsham wrote:

The pages are not remaining blown out now although they do still 'jump' initially when they load up and then fall into place.

That's normal behavior (and one of the problems with html "rules"). What is happening is that initially there is something on the page that is pushing things out. As more code is deciphered it overrides the original "rule" and it all "falls" into place. (There's a name for this that I forgetSad )

Meaning: Technically, there is something still not quite right. In my case, it works the opposite on purpose, it "snaps" out.

Reply
Friday, July 29, 2011 at 7:06 PM - Response #10

Thanks for your input, Jack. These things are sent to try us but try as they might we won't let them get us down!Laughing

I think we're better off not understanding why.ConfusedSmile So long as it looks alright in the end I'll suffer the journey's hiatus.

Cheers.

Reply
Friday, September 2, 2011 at 11:49 PM - Response #11

Kyle Erickson wrote:

No, I don't know when they will be released. I think they are part of the ClassCreator 3.0 code which the programmers are still working on.

Any 3.0 software programming development progress updates?
(I recall reading in the forums about how the unvieling and implementation was going to be in "the first quarter" of this year. So just curious.)

Reply
Edited 09/03/11 12:00 AM
New Topic  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.