ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Subscription Options  

Cannot link to non-SSL sites

Forums: General Discussion
Created on: 02/21/21 03:33 PM Views: 121 Replies: 5
Sunday, February 21, 2021 at 3:33 PM

Okay, maybe we shouldn't be doing this, but we've had a site maintained by a classmate for more than a decade. He's kind of old school, and does not have a certificate for his site.

We put a link to it as http://swarthmore71.org in the "add a link" option for the ClassCreator editor. I also tried just putting "http"+ "://swarthmore71.org" in plain text. In both cases the "http" was converted to "https" -- and going to the link https://swarthmore71.org throws an error.

Just wondering if there's any way around your global search and replace so that we can use a link to that old site.

Reply
Edited 02/21/21 3:34 PM
Sunday, February 21, 2021 at 6:34 PM - Response #1

Nancy,

Here's a workaround solution that works: Instead of having a clickable link to swarthmore71.org, instruct classmates to type "swarthmore71.org" onto the URL line in their browser. Don't add anything more when you type it in the URL line, just swarthmore71.org. Type this exact phrase in the URL line and you'll go to the site.

An example might be:

"We have a sister site for our class. You may access it at swarthmore71.org. Type the exact phrase "swarthmore71.org" in your browser's search box."

In short, by not having a link, you'll force anyone who wants to go to the site to type "swarthmore71.org" on the URL line of their browser, which will take them to the site.

Reply
Edited 02/21/21 7:32 PM
Sunday, February 21, 2021 at 7:40 PM - Response #2

Nancy, I just added the link name http://swarthmore71.org using the Editor Link feature and it worked fine as a clickable link. It did not change it to https although it did add "index.html" sort of a default thing.

I also added it as plain text and that also worked fine, except it was not clickable.

What you wrote is slightly different and not the actual link reference. Maybe I'm not interpreting what you said correctly? Just use http://swarthmore71.org without any other characters.

Reply
Sunday, February 21, 2021 at 8:36 PM - Response #3

Hi Nancy,

Try it again now. It was behaving a bit differently earlier but it should work now. Jack also mentions testing it so you should be all set if you try again. We were checking for images that were not secure and updating them for users on the fly so they wouldn't have to manually change them all and the script was over reaching a bit - it shouldn't now.

Jessica
Class Creator Support


Reply
Tuesday, March 2, 2021 at 1:08 PM - Response #4

Yes, it does seem to be working now. (But I'm not sure why I didn't get email about the replies to the question. Belated thanks to everyone.)

Reply
Tuesday, March 2, 2021 at 2:18 PM - Response #5

Nancy, at the bottom of this page, see if you've checked "Yes" to "Email me all responses to this thread, Cannot link to non-SSL sites?" If so, I don't know what's going on.

Reply
Edited 03/02/21 2:20 PM
New Topic  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.