ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Reply Subscription Options  

Uploading photos

Forums: General Discussion
Created on: 04/06/17 02:28 PM Views: 749 Replies: 6
Thursday, April 6, 2017 at 2:28 PM

I am an admin and when I try to upload a photo from the desktop (jpeg format) to "post a comment" all I get is "Uploading ... 100%" for hours at a time and nothing ever shows up. When I try e-mail the class and select "image" I get this error message " ('CFX_ImageCR Exception', 'vGetFindData failed for file: "d:\\inetpub\\classcreator\\temp\\B&W
Joyce:Skip 0943.jpg"')

I am using an iMac and Safari (also does the same for Firefox). I have successfully uploaded pictures in the past.

Skip Osborn

Reply
Thursday, April 6, 2017 at 3:29 PM - Response #1

Usually that means the image is not really a JPEG. Some programs can figure this out (by examining the file header) but CC gets an error.

Or to put it another way, the filename suffix does not reflect the actual file format. The way this happens is saving an image using a suffix different from the actual format. For example a .PNG is given a .JPG suffix.

JPG = JPEG, PNG and GIF are the three most common image formats but there are also others.

You might be able to attach it here so we can see - not sure if the forum will handle but easy to test.

Reply
Edited 04/06/17 3:30 PM
Tuesday, April 11, 2017 at 2:46 PM - Response #2

The problem was the punctuation in the filename. Namely the & symbol. I use a Mac and OS-X allows most characters in filenames, where Microsoft has severe limitations. It would have been handy for the error message to identify this. After removing the "&" it loaded the pictures normally.

Thanks to Jessica from Class Creator Support.

Reply
Tuesday, April 11, 2017 at 3:30 PM - Response #3
img&test.png

Except & is a perfectly fine character in Windows too. The problem is probably that the upload program gets confused by the &, not MS.

Attached is a filename with an & in Windows. There are very few practical differences between the two. One are characters that are not actual characters. Pretty hard to create manually Smile

(Edit: First time I uploaded file didn't show and I thought maybe browsers don't like &, but I think that's a bug in preview here where it removed the file? Shows fine now)

Reply
Edited 04/11/17 3:35 PM
Tuesday, April 11, 2017 at 3:54 PM - Response #4

Cancel that - it's something else. I just uploaded a PNG, JPG, and GIF with an & in the filename as a comment in "What's New". ALL initially uploaded and posted fine. However, when I went back, they all disappeared after I tried the same thing on a profile and nothing worked. So I went back to WN and nothing there now either (did show first time).

Says < img id="photo_" src="" rel=""> Twisted Evil

Reply
Edited 04/11/17 3:56 PM
Tuesday, April 11, 2017 at 5:12 PM - Response #5

Similar results here. I was able to upload a photo with an ampersand in the file name as a What's New message. Looked as expected. Then tried to upload the same photo in a member's profile. Loading spun, said 100% complete, but no photo showed up. But... We have seen that before though, with other 'normal' photo's.

Went back to What's New, photo was still there. Got out, cleared java and browser cache, temp files, etc. Logged back in and the file in What's new was still there, as well as in my profile since I'd added the WN message. But still no photo in the member's profile I'd uploaded it to.

Tried once again to upload it to a different member's profile. Same results. Uploading, 100%, no photo.

One more test, adding that photo to a page using the editor. Worked as expected.

Something in the interface with Amazon AWS?

Reply
Tuesday, April 11, 2017 at 6:38 PM - Response #6

Yup, it's pretty odd how it is behaving. I got one to "stick" in WN but can't do it with another one. The one that worked is PNG - although that's probably a coincidence.

Reply
New Topic Reply  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.