ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Subscription Options  

Help please! Gallery not working in responsive design

Forums: Questions and Answers About Building Your Site
Created on: 01/02/21 07:03 AM Views: 411 Replies: 16
Saturday, January 2, 2021 at 7:03 AM
Screenshot (5).png

I switched to the Responsive Design & love how it looks but just found out my gallery is not working. It shows the gallery categories but when you click on one to see the photos, all I see are empty boxes. What happened and how do I fix it? I'm attaching a pic of what it looks like. Thanks in advance!

Reply
Sunday, January 3, 2021 at 5:28 AM - Response #1

I posted the same question in another forum; sorry about that - I deleted it.
I must be too tired having tried everything I can think of to get my gallery to work again. I deleted everything and started over, but still all I see is an empty box Sad

Reply
Edited 01/03/21 5:30 AM
Sunday, January 3, 2021 at 6:38 AM - Response #2

How about temporarily reactivating the gallery page and unlocking it so some of the class administrators who are techies can see a little deeper and maybe offer suggestions. Edit Site Pages > Gallery page > Edit Link > uncheck "Restrict to Classmates only."

Reply
Edited 01/03/21 6:45 AM
Sunday, January 3, 2021 at 7:01 AM - Response #3

Done Scott, thanks!

Reply
Sunday, January 3, 2021 at 7:46 AM - Response #4

Sandy, I've sent you a private message (click on Inbox at the top of this page). Would enjoy speaking with you about a couple other things I see on your site. Thanks!

Reply
Edited 01/03/21 8:05 AM
Sunday, January 3, 2021 at 10:08 AM - Response #5

Responded to your inbox Scott but hoping someone from CC can help me fix this problem Sad

Reply
Edited 01/03/21 10:25 AM
Sunday, January 3, 2021 at 4:31 PM - Response #6

The gallery issue is party my fault and CC's fault. There is an error message about https that is preventing the browsers from displaying the images. It's sort of invisible unless one goes into debug mode and play around.

This was caused by the script I wrote making all pages "secure". I was not aware the gallery format would cause a problem.

For now, I modified the script so it does nothing until I get some time to look into gallery sequences.

You might have to clear your cache to pick up the new script code. Usually Ctrl+F5 works, but sometimes it has to be done the long way.

Reply
Sunday, January 3, 2021 at 6:08 PM - Response #7

Thanks Jack I'll try that as soon as my dinner company leaves (no idea how long they'll stay lol)

I love the code you gave us to remove the Not Secure message! People are so freaked out so if I have to do without the gallery to have that, it's a fair trade I guess. Many thanks for your response! I'll let you know if it helps.

Reply
Sunday, January 3, 2021 at 7:34 PM - Response #8

Jack, I just had a thought - what if I put the script on all individual pages except the galleries - would that work?

Reply
Sunday, January 3, 2021 at 8:37 PM - Response #9

Hold on a bit. I think I can fix it. The problem is that s3images.classcreator.com is not an authorized user of the secure certificate (I make all images https, otherwise a page will be marked not secure).

This is actually something CC has to fix before they themselves offer the security. There's another image issue they have on a responsive home page option that I'm not sure they have fixed yet.

I think I can ignore s3images.classcreator.com but those images will then show up as not secure. IOW, the gallery page will show as not secure.

Reply
Sunday, January 3, 2021 at 8:42 PM - Response #10

Ok my friend, I'm in a holding pattern (you're awesome btw!)

Reply
Sunday, January 3, 2021 at 9:04 PM - Response #11

I think it's all working now. Be sure to refresh the page Ctrl+F5 or clear the cache.

You can tell since the side links show https but on the gallery page they do not show https.

FYI the Jukebox works on Android phones. Haven't tested current IOS (Apple - only have prior version) but should work there. It's all Javascript+html5.

Reply
Sunday, January 3, 2021 at 10:18 PM - Response #12

Yep, it works great on Apple devices.

Reply
Monday, January 4, 2021 at 12:38 AM - Response #13

thanks for confirming Idea

Reply
Monday, January 4, 2021 at 5:59 AM - Response #14

Hmm gallery was working again when you made the script do nothing but is back to not working now. I cleared my cache like you said but gallery is back to showing nothing but empty boxes when you try to see photos inside the gallery categories (gallery categories show just fine)

But that's ok for now! Like I said, it's more important to me to get rid of the Not Secure message!

As for Jukebox, I do have an older iphone (6plus) so maybe that's why the jukebox doesn't work for me?

Reply
Monday, January 4, 2021 at 1:05 PM - Response #15

Forgot one link. Will fix when I get home. Browsers remembered the past so did not show up.

Reply
Monday, January 4, 2021 at 5:23 PM - Response #16

Thanks Jack! You & Scott are my new best friends lol

Reply
New Topic  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.