ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Reply Subscription Options  

Linking images to open new web address

Do you see anything amiss?

Thanks!
Terry

Forums: Questions and Answers About Building Your Site
Created on: 02/19/09 10:51 AM Views: 1629 Replies: 20
Thursday, February 19, 2009 at 10:51 AM

I want to hyperlink our sponsor's ad (an image file) to their website. I thought I knew how to do this but it's not working. Rolling Eyes

Here's the html code I entered:

Can someone point out what I've done wrong?

Thanks!
Terry

Reply
Thursday, February 19, 2009 at 10:53 AM - Response #1

try using IMG SRC= instead of INPUT CLASS


Reply
Thursday, February 19, 2009 at 11:00 AM - Response #2

Kyle Erickson wrote:

try using IMG SRC= instead of INPUT CLASS

Hi Kyle, thanks for the idea. I tried it; now the link works but the image is represented with an "x".

I'm ready to for more ideas if you have any Smile

Thanks!
Terry

p.s. went back to look at the code, and it got altered somehow, like so:

Reply
Edited 02/19/09 11:03 AM
Thursday, February 19, 2009 at 11:04 AM - Response #3

If you are seeing an X, it means the image can't be found. Are you sure you have uploaded the image to the system and have the correct image name?

If you are still having problems, you can have the image be external to the site, on another web page by including the "http://www." address of the graphic.


Reply
Thursday, February 19, 2009 at 11:09 AM - Response #4

Do what Kyle suggested above, but make sure when you insert your image path you use the whole path, which is:

http://www.classcreator.com/userfiles/Image/WOW_Business_Card.jpg

Your file is there. It should work fine.


Reply
Thursday, February 19, 2009 at 11:49 AM - Response #5

Thank you both for your help. I'm still missing something though and can't get it to work... could the problem have anything to do with tables? (I'm using a table to keep all the images in neat columns/rows...)

Here's the code for the entire cell:


SAMPLE (BUSINESS CARD IMAGE)


Reply
Participant: Log in to see names Thursday, February 19, 2009 at 12:29 PM - Response #6

Maybe a browser cache problem. Try refreshing the browser or trying a different browser. When I view this forum using RSS (top-right, next to Logout) I can see the business card just fine and click on it just fine.


Reply
Participant: Log in to see names Thursday, February 19, 2009 at 12:52 PM - Response #7

I see what you mean Kyle. Don't know why I didn't think of that before... going to try it now. Thanks!

Reply
Participant: Log in to see names Thursday, February 19, 2009 at 12:58 PM - Response #8

Use IMG SRC= instead of INPUT CLASS. That should work fine. What page of your site is this on?


Reply
Participant: Log in to see names Thursday, February 19, 2009 at 12:59 PM - Response #9

Brad Switzer wrote:

Use IMG SRC= instead of INPUT CLASS. That should work fine. What page of your site is this on?

I was just getting ready to post that Smile
It's here: http://www.fhhs79.com/member_dosurvey.cfm?SurveyID=4079

Thanks Brad!
Terry

Reply
Participant: Log in to see names Thursday, February 19, 2009 at 1:02 PM - Response #10

Brad Switzer wrote:

Use IMG SRC= instead of INPUT CLASS.

When I do that, the image goes away.

Terry

Reply
Participant: Log in to see names Thursday, February 19, 2009 at 1:27 PM - Response #11

Michelle Johnson has a solution on her site at http://www.greenon88.com/class_custom8.cfm that, when I tried it, works on my site too. Not the solution I wanted, but I can go with it for now... (Right click and select "Open Link in New Window")

Please let me know if you figure out how to do this without the work-around Smile

Thanks!
Terry

Reply
Participant: Log in to see names Thursday, February 19, 2009 at 1:31 PM - Response #12

I changed it to img src on your site and it's working fine. Click Source and check the code.


Reply
Participant: Log in to see names Thursday, February 19, 2009 at 1:38 PM - Response #13

Thanks Brad! I see it is working,Very Happy but I honestly don't see what you did. I viewed the source, and to me it looks the same:


SAMPLE (BUSINESS CARD IMAGE)


I'm going to compare & study this code against the one I pasted earlier, maybe I can figure it out!

In any case, thank you very much!!!
Terry

Reply
Participant: Log in to see names Thursday, February 19, 2009 at 1:42 PM - Response #14

Terry Alers wrote:

Thanks Brad! I see it is working,Very Happy but I honestly don't see what you did. I viewed the source, and to me it looks the same:


SAMPLE (BUSINESS CARD IMAGE)


I'm going to compare & study this code against the one I pasted earlier, maybe I can figure it out!

In any case, thank you very much!!!
Terry

Okay, now I see it...

This entire string: input class="" type=
was replaced with: img

src= was always there.

Thank you!!!

Reply
Participant: Log in to see names Thursday, February 19, 2009 at 2:06 PM - Response #15

Most welcome. Smile


Reply
Participant: Log in to see names Tuesday, March 10, 2009 at 6:44 PM - Response #16

How do I add a image to my site? I clicked on the image icon, but nothing is happening? This will be on our donations/sponsors page.

Thanks~

Reply
Participant: Log in to see names Tuesday, March 10, 2009 at 7:01 PM - Response #17

Make sure you are using the latest version of Internet Explorer or Firefox to add images to your site. Also make sure you're not blocking popup windows, because the image uploader launches in a new window when you click the yellow image icon.


Reply
Participant: Log in to see names Tuesday, March 10, 2009 at 7:05 PM - Response #18

Okay, thanks! I have another issue...go figure, LOL! I'm trying to upload my classmates, but the form classcreator provides doesn't allow me to save it (probably because I opened it before and didn't hit save, but open).

What should I do now?

Thanks~

Reply
Participant: Log in to see names Tuesday, March 10, 2009 at 7:16 PM - Response #19

1) Shut down your web browser
2) Open it back up
3) Log into your site again
4) Go back to the Upload Classmats area
5) Click to download the import template
6) Save instead of open


Reply
Participant: Log in to see names Wednesday, July 27, 2011 at 2:00 PM - Response #20

Whoops! Something (in the pasted codes I'm guessing) has blown out this page... yikes Shocked

Reply
New Topic Reply  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.