ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Subscription Options  

email for our domain name

Forums: General Discussion
Created on: 04/04/11 09:38 PM Views: 1613 Replies: 18
Monday, April 4, 2011 at 9:38 PM

We'd like to set up an email address using the domain name we purchased from you. In using Google email which is free, a change may need to be made to our domain records, not sure. In any case, do you have experience with other alumni groups setting up a separate email beyond what is provided in the Contact Us link?

Reply
Monday, April 4, 2011 at 10:09 PM - Response #1
Google-Verify-Ownership.jpg

In trying to set up an email address on Google for our domain name, I came up with the attached page - are any of these things possible for us to verify our domain?

Reply
Tuesday, April 5, 2011 at 10:40 AM - Response #2

You can add a DNS record to your domain name.

1. Login to http://www.classnames.net
2. Choose Domain > My Domains from the dropdown menus across the top of the screen.
3. Select the Domain name from the list and click the domain name to go to the details page for that domain

Determine if they are having you add a A Record / CName or MX Record.

If they want you to add an A Record or CName then go to Item 4. If they want you to add an MX Record go to Item 5

4. Scoll down to the "Host Records" portion near the bottom of the page. This section lets you add a record to the existing domain record.
If they offer you the option to add a record to an existing entry this is where you would add it. There is an Edit link near the top of the Host Record section.

Note that you do not want to change the DNS Servers if you can avoid it. Some companies will offer two options - adding a record or changing the DNS servers. The DNS servers are preconfigured to auto-connect to your class site so you'll want to keep those assigned as they are now and simply add an additional record if needed.


OR

5. If they specifically ask you to add an MX record then you will need to do the following:

Near the top of the domain details page there is a title called Domain Manager with a group of tabs under it (My Domains / Expired / etc.) that end with a dropdown tab called More. Select the More tab and choose the MX Record option. Add the settings provided and save.

Note that you do not want to change the DNS Servers if you can avoid it. Some companies will offer two options - adding a record or changing the DNS servers. The DNS servers are preconfigured to auto-connect to your class site so you'll want to keep those assigned as they are now and simply add an additional record if needed.

Jessica
Class Creator Support


Reply
Saturday, February 9, 2013 at 10:16 AM - Response #3

I tried to do this and am having a problem. I set up a gmail account. Under MX Record it has a place to enter HOst that has an @ in the box. I tried both gmail.com and my domain name and it told me both were invalid. It then has another box for address, so I entered both the first part of my email address I set up and then tried the entire email address. There is also a box marked pref and it has a number 10 in it. I don't know what any of this means. Will this cause our emails generated on the class creator site to come from our email address rather than noreply@ class creator. That is the main reason we bought a domain and the email generated still is coming from classcreator.com. What exactly goes in the boxes. Am I in the right place?

Reply
Monday, February 11, 2013 at 11:31 AM - Response #4

LaVerne,

You have a Platinum level subscription with us, so you already have the option of having email at your domain directly through us. This is also the only way that emails sent from your website can come from an address at your domain rather than from noreply@classcreator.net.

To turn on Platinum email, go to your Preferences page and check the box in the green section next to Platinum E-mail, and then check the names of the admins on your site to whom you wish to assign mailboxes.


Reply
Tuesday, February 12, 2013 at 10:47 PM - Response #5

Thanks Eric,

I turned on the email in Preferences, received emails announcing the new email address and I configured my email address on the website. I tried to send a test to myself from a draft of an email I created to announce the new domain name. I received the test just fine on Saturday to see if the from email had changed. This was before I changed the email preferences . Tonight I selected to send from my new email (laverne@planters1969-1972.com)that was available in the drop down, to my personal email that is on my profile on the site, but I did not receive the email. I tried several times. I created a new email to all classmates and teachers and again selected my new email for the from and sent a test to my personal email. I got the message "Your test message was sent from LaVerne Burkett Cribbs to the following email address: mlcribbs@tampabay.rr.com on 02/12/13 10:31 PM. Also, a draft was saved." However, I did not receive the email this time either. It is not in my junk folder. I have been receiving all other emails from the site. Is there something else that needs to be set up before this works?

Reply
Tuesday, February 12, 2013 at 10:51 PM - Response #6

By the way, when I try to send the test from my original email, which is the site email address, it didn't work either. I don't think I am doing anything different from what I have done in the past, except I turned on email preferences.

Reply
Wednesday, February 13, 2013 at 10:45 AM - Response #7

There was a mail backup this morning, but it may have started last night. I'd suggest trying your tests again today.


Reply
Wednesday, February 13, 2013 at 12:50 PM - Response #8

I just tried to send from both the original email and the new one again. I am using a draft and choosing to send test. Nothing is coming through. Is there a time delay? It has been 5 minutes and I have clicked send/receive several times to check my email.

Reply
Wednesday, February 13, 2013 at 1:11 PM - Response #9

LaVerne, I just sent myself a test message from your Email the Class page, and it came through just fine within a few minutes. Please give it another try.


Reply
Wednesday, February 13, 2013 at 11:16 PM - Response #10

Still not working for me using either email address.

Reply
Thursday, February 14, 2013 at 10:49 AM - Response #11

The problem is not on our system, which I demonstrated by successfully sending myself a message.
If you cannot find the messages in the spam or junk folders in your email, then the only option remaining is to take it up with your email service provider, because they are failing to deliver to you email that we send.


Reply
Thursday, February 14, 2013 at 11:06 AM - Response #12

I have never had a problem before and I received the one before I changed the Preferences to Platinum Email just fine. That is why I thought it should be something with the settings that I changed.

Reply
Thursday, February 14, 2013 at 11:22 AM - Response #13

Here is our suggestion for dealing with this, since we believe that the problem is not your settings, but is with your email provider.
1. Go to gmail.com and register there to get a free email address at gmail.
2. Add your new gmail address as an alternate address to your Contact Details.
3. Send yourself an email from Email the Class (not using the send test feature, just select yourself as the only recipient).
4. After a few minutes, check your gmail account (and be sure to check the spam/junk folder just in case.
5. Since we are confident you will have received the message in your gmail, then you can complain to Roadrunner about their failure to deliver legitimate email and show them the message you received at gmail to validate the complaint.


Reply
Sunday, February 17, 2013 at 9:08 AM - Response #14

Ok, so I did what you said and tested 4 emails that I already have. They did come through, but as junk mail. So when I checked the junk today, I see the ones from the 13th that I originally sent, so it must have been the mail back up that was causing the original problem, because they were not in the junk folder on the 13th.

However, I thought that the new domain name was to help prevent the messages from going into junk folders. Is there anything I can do on our end to decrease the likelihood of our communication going to junk mail? I know they need to whitelist it, but if they never get the first message, how will they know?

Reply
Sunday, February 17, 2013 at 12:51 PM - Response #15

Your email provider is Roadrunner, but what actual email software are you using to read the emails? What are your spam settings in that software? Or are you using webmail and Roadrunner itself is flagging the messages as spam?


Reply
Sunday, February 17, 2013 at 1:11 PM - Response #16

I am personally using outlook. I'm not sure what some of the others are using, but I know I have had some tell me that they were not receiving the emails even after they had joined the website. I have sent everyone with emails (226)that has not joined yet an email from my personal gmail account asking them to add our new admin emails to their safe sender list as well as the website to their safe site. I've sent an email to all the members from my primary email address that I had been using to let them know of the domain change and to add the new website and emails to their safe lists. I know that our welcome email tells everyone to whitelist, but I don't know if they do or not. I'm just trying to make sure, as much as possible, that our emails from the site are getting through to people.
I thought I had read that coming from our own domain name they would be less likely to get caught in spam filters, so I was just surprised that mine did. Maybe I should not have been.

Reply
Sunday, February 17, 2013 at 7:20 PM - Response #17

It should be less likely, however, the receiving email providers can change their filters at any time. If you are getting the messages in your spam folder they are coming through (I'm not seeing them as a bounce). Does Road Runner give you the option to whitelist your domain? If you whitelist your domain as well as class-creator.net with the dash between class-creator as that is the name of the primary mail server that manages all of the platinum email servers. Some providers read that as part of the header so it might help to whitelist both.

Jessica
Class Creator Support


Reply
Sunday, February 17, 2013 at 9:16 PM - Response #18

Jessica, from my interpretation Outlook is sending them to Spam, -not- RoadRunner. IOW, I think it's a setting in Outlook.

LaVerne, Gmail is probably the very best spam filtering system I've ever used. You can have both Gmail and receive it via Outlook. IOW, make Gmail your one and only email address. Then have Outlook leave the mail on Gmail when you retrieve. (You can still get your 'old' address too.)

This makes mail management much simpler plus you get a lifetime email address vs one linked to a provider. And you have a backup that will last a long long time.

I haven't used Outlook for a long time, but pretty sure you can configure it to retrieve multiple email accounts. That's what I do, just not Outlook.

However, Gmail now offers another method LINK

Reply
New Topic  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.