ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Subscription Options  

Home page is messed up

Forums: General Discussion
Created on: 05/13/11 08:43 AM Views: 1228 Replies: 11
Friday, May 13, 2011 at 8:43 AM

I haven't had problems before posting a new announcement. This time I went in to make a new one and posted a youtube video. I used the 640 size and did this correctly. However, the home page seems to have a mind of its own this morning. When I log on, practically everything has disappeared from home page. I have gone into edit annoucements and when I view,the boxes are checked active. I have done this several times and sometimes everything shows as it was, in view mode only, and then sometimes, the only thing showing is the recent video posted and it is way down at the bottom, below alot of empty space. This is in view mode. The actual home page has nothing under announcements. Please advise. Thanks!

Reply
Friday, May 13, 2011 at 10:09 AM - Response #1

For the home page, youtube video maximum width is around 398 (gives a bit of room of font size differences). That's what made everything "sink" to the bottom.

That's for video, graphics, images, etc that "fit" between the left margin and the right one below the login with various options. Once you get past the right side stuff, then you can go to the size you have.

Reply
Edited 05/13/11 10:11 AM
Friday, May 13, 2011 at 11:58 AM - Response #2

Hi Lori,

You can edit the size of the youtube video by clicking on the source button in the upper left corner of the site page editor and then finding the youtube source and editing the width down to 398 as Jack suggested. If there is more than one width reference in the code you need to edit each of them. I typically also edit the height to keep it proportional.

Jessica
Class Creator Support


Reply
Friday, May 13, 2011 at 5:37 PM - Response #3

Thank you~ I changed the size to the smallest choice available on you tube. The video is working and is on home page. All announcements and this clip are way below, still. I want it to be underneath the music player. Check it outSmile I appreciate your help!

Reply
Friday, May 13, 2011 at 9:54 PM - Response #4

Use the Custom setting all the way on the right of all the choices. Type in 398 for the width and height autos to 328.

You can also manually just key in those values in source mode - as Jessica noted.

Reply
Tuesday, May 17, 2011 at 1:55 PM - Response #5

I have made the dimensions to be 398 and 328. Nothing changed. If you look on our home page, you will see that the announcements have not moved up. I am still stuck. Will someone be able to educate me as to what has caused this? and how it can be corrected? Thanks in advance. Lori

Reply
Tuesday, May 17, 2011 at 2:12 PM - Response #6

You have the youtube inside of a table set at 100%. As it loads, the browser is probably picking up the full width (which exceeds 398 - somewhere around 600).

So manually reduce the table to 398 or remove it for a second so you can verify my comment.

Reply
Tuesday, May 17, 2011 at 2:15 PM - Response #7

WOW, the comment that posted above is actually mine. I was going to edit it since I remembered one other reason the table can go wide - something else inside the table is pushing it beyond 398.

Removing the table will show what object is wider.

Reply
Tuesday, May 17, 2011 at 2:29 PM - Response #8

I have made it inactive and now the page is back to normal. I look at the source code and it has the dimensions correct. I do not know how to change it manaully. If source says its right, does that mean it isnt necessarily? When you say to remove the table, to see what is wider, what do you mean? I am learningSmile I have posted youtube clips before and never ran into this. I dont know what changed since then but obviously I am confused. sorry

Reply
Tuesday, May 17, 2011 at 2:40 PM - Response #9

OK, you have bullets (the "dot") in front of your data that is pushing the content wider - in this case the youtube.

This is what it looks like in source mode the little DOT is • the issue (forum code still has a bug here - should be & # 8226; (remove spaces shown since I had to do that so you could see what it looks like) These "dots" are inf front of all your announcements)                           
I suppose technically it might be the cell that they are in (td) so you need to remove that too.

That's probably still a bit too abstract. When Jessica talked about the "source" button, that's the easiest way to tackle some of the not obvious problems since it shows you the underlying html code that creates your pages.

Don't worry about messing anything up by clicking it. It's a good thing to learn and this is as good a place as any. When you see anything with < stuff > that's the start of html commands. They usually end with < / stuff > meaning the end of the command.

What you have sets the font, color and a special bullet character.

Reply
Edited 05/17/11 4:09 PM
Tuesday, May 17, 2011 at 3:50 PM - Response #10

I couldn't access the forum for a bit, but noticed you fixed it perfectlyRazz

There's one stray leftover < you might want to delete.

Reply
Tuesday, May 17, 2011 at 5:02 PM - Response #11

Brilliant! Thank you! Who would have thought that?! lol I just checked the option box to not have the dot appear before the announcement, and it seemed to have corrected the problem. The help is soooo appreciated! I went in to reply back earlier but message forum was down.

Reply
New Topic  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.