ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Reply Subscription Options  

Announcement for non-logged in

Forums: Questions and Answers About Building Your Site
Created on: 04/17/10 01:58 AM Views: 1425 Replies: 14
Saturday, April 17, 2010 at 1:58 AM

I want to create a First Visit announcement that's viewable only to visitors "not" logged in. I can't seem to figure this out. Can someone please advise?

At the present time I have my First Visit message typed in my "content" box on the home page but it's also viewable by classmataes that are logged in. I want it hidden from logged-in folks.

Thank you,
Cheryl

Reply
Saturday, April 17, 2010 at 9:13 AM - Response #1

I don't know if this will help, but I've set-up my entire first page for first-time visitors. It's not hidden from logged-in classmates; I think it's a pretty good intro for all.

Classmates are directed to another password protected page for all the class news.

Take a look, if this sounds like something that might work for you.

Reply
Edited 04/17/10 9:14 AM
Saturday, April 17, 2010 at 9:16 AM - Response #2

1. Click on "Post Announcement"
2. Create New Announcement
3. type a name (if you want)
4. choose "Non Logged In Only" from "display to" drop-down
5. Type your First Visit message
6. Save Changes
7. ACTIVATE THE ANNOUNCEMENT


Reply
Edited 04/17/10 12:36 PM
Saturday, April 17, 2010 at 9:21 AM - Response #3

Kyle, I've been playing with the announcements, and would like to scatter them throughout my homepage, but I can't seem to see a way to position them; they all just "stick" to each other at the top. Is there a way to move them around?

Great news on the "non-logged in" only. I missed that one!

Reply
Edited 04/17/10 9:22 AM
Saturday, April 17, 2010 at 9:54 AM - Response #4

The announcements all stick to each other so they are all in one section - you cannot scatter them throughout your home page.

You can either have them ABOVE or BELOW your main content. To move the location of your announcements, go to Edit Site Pages, Edit Home Page. Now move the Red/Green arrows next to "Announcements" and "Your Content". If "Your Content" is first, then announcements are below. If "Announcements" is first, then they are the top of your home page.


Reply
Saturday, April 17, 2010 at 11:19 AM - Response #5

Another option for you..

I used one of my custom links-

How Do I Join? Then on the home page, welcomed them and asked if this is their first visit, please click on "How Do I Join?" I did not password protect that link..

You can check it out on my site, if you wish..Copy any verbage you want..

Reply
Saturday, April 17, 2010 at 11:30 AM - Response #6

I've tried a number of times to use the "non-logged in" feature for an announcement, but it doesn't work for me. that's why I'm asking all you gurus.

I create an announcement, check that it's for only non-logged in visitors. I log out and visit the home page and it's still not there.

It looks like it should be easy to do but I'm having a senior moment, I guess. Has anyone else been successful using this feature?

Reply
Saturday, April 17, 2010 at 12:37 PM - Response #7

Cheryl Kemptner wrote:

I've tried a number of times to use the "non-logged in" feature for an announcement, but it doesn't work for me. that's why I'm asking all you gurus.

I create an announcement, check that it's for only non-logged in visitors. I log out and visit the home page and it's still not there.

It looks like it should be easy to do but I'm having a senior moment, I guess. Has anyone else been successful using this feature?

OK, I added a 7th step to my instructions: ACTIVATE THE ANNOUNCEMENT.

What is the name of the announcement you are having problems with? If it is called "First Time Visitors" then you need to activate that announcement.


Reply
Saturday, April 17, 2010 at 12:48 PM - Response #8

Kyle Erickson wrote:

Cheryl Kemptner wrote:
I've tried a number of times to use the "non-logged in" feature for an announcement, but it doesn't work for me. that's why I'm asking all you gurus.

I create an announcement, check that it's for only non-logged in visitors. I log out and visit the home page and it's still not there.

It looks like it should be easy to do but I'm having a senior moment, I guess. Has anyone else been successful using this feature?

OK, I added a 7th step to my instructions: ACTIVATE THE ANNOUNCEMENT.

What is the name of the announcement you are having problems with? If it is called "First Time Visitors" then you need to activate that announcement.

Thanks, Kyle,

When you looked at my announcements I had deactivated that announcement. My problem is that when I do activate it, I still do not see it when I log out.

Is there something else I'm missing?

Reply
Saturday, April 17, 2010 at 1:43 PM - Response #9

Cheryl...if the annoucement in question is the big "click here to register" button, then I see it.

You probably need to clear your cache (temporary internet files).

Reply
Edited 04/17/10 1:44 PM
Saturday, April 17, 2010 at 2:25 PM - Response #10

Marian Wright wrote:

Cheryl...if the annoucement in question is the big "click here to register" button, then I see it.

You probably need to clear your cache (temporary internet files).


I activated the first visit announcement that's for "non logged in only." Then I deactivated my home page "content" then deleted all temp files.
When I log out, the whole announcement area is blank on my home page.

What I'm tryiing to do is delete my "content" big button and make a separate announcement with the big button that's only seen to non logged in visitors.

Right now the logged-in visitors see the great big button at the bottom of my home page and I don't want it to show if someone is logged in. That's why I want to create a "non logged in only" announcement.

Does that make sense?

Reply
Edited 04/17/10 2:28 PM
Saturday, April 17, 2010 at 2:34 PM - Response #11

It makes perfect sense. If you have your content deactivated, then I am seeing your announcement (the button and the related text are the only things I see).

Have you tried another browser?


edit: I also see a horizontal line below your right hand modules, is that in your announcement?

Reply
Edited 04/17/10 2:40 PM
Saturday, April 17, 2010 at 2:45 PM - Response #12

Marian Wright wrote:

It makes perfect sense. If you have your content deactivated, then I am seeing your announcement (the button and the related text are the only things I see).

Have you tried another browser?


edit: I also see a horizontal line below your right hand modules, is that in your announcement?

No, what you are seeing is the content. I couldn't leave my home page blank very long. We have a multi-year site and too many new classmates are visiting. Just since last night at 6:00 I have had 67 new members.

Any other suggestions, folks?

Reply
Edited 04/17/10 4:07 PM
Saturday, April 17, 2010 at 4:17 PM - Response #13

Edit Site Pages
Edit Home Page

Announcements [Logged in only]

Since you have your announcements set to ONLY SHOW FOR LOGGED IN CLASSMATES, none of the overrides for individual announcements mean anything.

What you need to do is on this page UNCHECK the box to show announcements only to logged in classmates. Then you can pick and choose which announcements you want for logged in and non-logged in.

This will solve your problem.


Reply
Saturday, April 17, 2010 at 4:28 PM - Response #14

Yep, that was the magic button! Thanks, Kyle! I can't believe I couldn't figure that one out.

Thanks, everyone else, that made suggestions. I'll bet lots of us learned something new here.

Cheryl

Reply
New Topic Reply  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.