ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Reply Subscription Options  

Threaded forum question

Forums: Suggestions and Feedback
Created on: 05/31/09 02:51 PM Views: 1391 Replies: 12
Sunday, May 31, 2009 at 2:51 PM

Brad,
I'm a little behind in getting the threaded forum live to our website. Was trying to copy the last topic we were discussing in the old message forum to the threaded forum but a bad code error was generated when I tried to copy it. I take it that You Tube videos can't be posted in the new message forum as this is the only problem that it could have been. The rest is just text. Am waiting on your response before I make this forum live. Thanks.

Reply
Sunday, May 31, 2009 at 4:45 PM - Response #1

The code error must have been caused by some other code that was copied. Not sure what it might have been, but YouTube videos will work just fine in the new threaded forums.


Reply
Sunday, May 31, 2009 at 5:04 PM - Response #2

Brad,
So I should be able to copy and paste old message forum posts to the new forum?

BTW, here is the error message.

Please correct the following error(s):
Sorry, your message contains an element that has been disallowed for security purposes. Please review the source code of your message and remove all of the following:

onclick
ondblclick
onselect
onmousedown
onmouseup
onmouseover
onmousemove
onmouseout
onfocus
onblur
onkeypress
onkeydown
onkeyup
onselect
onload
onunload
onerror
onsubmit
onreset
onchange

If you feel the code you have included in your message should have been allowed, please email a copy of your source code to info@classcreator.com and explain what you were attempting to do and why you feel your post should be allowed. We may consider writing a workaround to allow your code in the future.

I promise you there is no top secret code in here so we are still trying to figure out why it has been disallowd for security purposes....LOL....

Reply
Edited 05/31/09 5:17 PM
Sunday, May 31, 2009 at 5:12 PM - Response #3

Kevin,
How did you create the animated signature?
I need one with my name!
Jeanne

Reply
Sunday, May 31, 2009 at 7:16 PM - Response #4

Nevermind Brad, I figured it out. BTW, new forums look GREAT!! Keep up the OUTSTANDING work!!

Reply
Sunday, May 31, 2009 at 7:31 PM - Response #5

Great. I didn't realize it was that particular error. That one I'm very familiar with. There's a variety of things Classmates could enter into the forums (since we allow html) in an attempt to "hack" our system. So we pretty much put a blanket block on most of the things (Javascript, etc) to ensure nobody can interject programming code into our system that will allow them to hack in or otherwise wreak other types of havoc. We've already seen attempts several times in the past. Apparently there's people out there who have nothing better to do than to try to hack systems like Class Creator.


Reply
Sunday, May 31, 2009 at 8:21 PM - Response #6

Brad,
FYI....the only word that was on that list that I found in our posts was the first one...onclick....all i had to do was scroll down and remove it(it was on there numerous times) and we were fine.

Reply
Sunday, May 31, 2009 at 11:56 PM - Response #7

Jeanne,
I used google and I googled "Quill and Pen Signature"

This is the site I got it from...http://www.quill-signatures.com/quill

Reply
Tuesday, June 2, 2009 at 8:49 AM - Response #8

Could spell out the steps to insert a Youtube video on the threaded forum.

All we are seeing is the embed code on our screen whenever we're done.

Reply
Tuesday, June 2, 2009 at 10:37 AM - Response #9

Jake (Kelly) Tidmore wrote:

Could spell out the steps to insert a Youtube video on the threaded forum.

All we are seeing is the embed code on our screen whenever we're done.

Copy the embeded code from the Youtube. Then in your forum posting click on the source button. Paste your code from youtube. Then save or preview. (tip: be sure that if you write an intro to your video to hit the enter button at least once. It keeps the page from getting blown out and some of the intro from moving)

Reply
Tuesday, June 2, 2009 at 11:12 AM - Response #10

I'm assuming you mean in your Lionel Lounge and not your old fourms, correct? If so, the very first thing you want to do is dump the BBML editor (the editor we originally released with the forums). Instead, when you're inside of your forums, click your Preferences link and change the editor to the visual editor intead of the BBML editor. And then follow the directions on the post above this one to add YouTube videos to the forums.


Reply
Tuesday, June 2, 2009 at 11:44 AM - Response #11

Before reading all your messages, I had succeeded in getting a YouTube video on simply by following the same procedures used on the Message Forum - just copy the URL and paste it between the brackets that popped up.

Honestly, I kind of prefer this over copying the embed code. It's in line with the procedure we use on the Message Forum.

If there is an advantage one way or the other, I'd be glad to hear about it.

Reply
Tuesday, June 2, 2009 at 3:20 PM - Response #12

Yes, and no. Smile (can't I ever just give a simple answer?)

Yes, the original forums allowed you to just paste the YouTube video URL and then our system added all of the necessary embed code around it. Made it very easy for people who don't understand embedding to just copy and paste the link in there. Boom, there's your video.

No, one way isn't better than the other, however, I could make a pretty good argument that we should keep the embed code procedure consistent so all things work the same way. Once people know how to do it once, they can now embed other things if they want to, such as Photobucket slide shows or whatever else they might want to include.


Reply
New Topic Reply  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.