ClassCreator.com | Blockbuster sites, amazing reunions

Share Tips

New Topic Subscription Options  

Raw Posting of HTML file

Forums: Suggestions and Feedback
Created on: 01/10/11 07:35 PM Views: 1172 Replies: 2
Monday, January 10, 2011 at 7:35 PM

This is either going to be easy or very difficultCool

I do most of my page editing locally on my system and then copy/paste into the FCKeditor. This works most of the time, but sometimes the FCKeditor likes to use it's own idea of what html should look like, leading to some interesting changes to how a page looks. (Latest was its insistence that a cell requires at least a blank to be valid - making it impossible to design a cell height of 1 - which works in all the browsers)

If there was a checkbox to enable "raw" mode, which means that the editor will merely save the code I have pasted and not attempt to rearrange or modify any of the code, that would enable us to use the latest formats accepted by browsers and all that implies.

This isn't for everyone, but I bet there are a few more here that could use that sort of "bypass" option.

Reply
Edited 01/10/11 8:58 PM
Monday, January 10, 2011 at 8:15 PM - Response #1

Couple of things here:

1) Did you know if you add "&ascii=y" to the URL of the custom page you're editing, the system simply brings up a textarea instead of the editor? The html is all yours.

2) The Class Creator system has some built in functions that help you space things correctly. Most of the time these built in functions are beneficial, but every now and then may be preventing you from creating the exact spacing you are desiring. If this is happening to you, click on your "Source" button, and at the top of your source code on its own blank line, paste in this code:

< !--nohardspace-- >

(note in the code about there should be no space after the < carrot bracket and no space before the > carrot bracket -- I had to add the spaces so the code would display.)

Make sure you paste in the entire code above, complete with opening and closing carrot brackets. When you do this you are telling our system to discontinue helping you with spacing issues, and honor 100% of your html code exactly as you've entered it. If you are having any issues with html and display, try putting the tag above at the top of your source code, and the issue will likely be solved.


Reply
Edited 01/10/11 8:44 PM
Monday, January 10, 2011 at 8:46 PM - Response #2

The ascii=y I knew about (from an "iframe" issue) and also now remember reading about the 2nd one. Till I run into something I forget everything I readWink

So rather than rely on my poor memory, it would be user friendly to add that as an explicit page option (and instructions on the edit page) vs having to recall exactly what to do to bypass FCK modifications.

I have to pass this on to the other admins so this sort of further info would remind them what Jack told themIdea You see, the page I was modifying is not really mine, I was fixing some formatting issues and ran into a little "surprise".

I'll add that to the page though and test it out.

Thanks

Edit:
nohardspace does not prevent the FCKeditor inserting a blank in the table cell. So acscii=y is the only option, which is not really a friendly solution.

Can you add another keyword like nohardspace that says "don't touch"? Or is this an oversight in the code?

Reply
Edited 01/10/11 9:05 PM
New Topic  
Subscription Options: Have all new forum posts sent directly to your email.
Subscription options are available after you log in.